summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-06-26 14:35:41 +0800
committerfanquake <fanquake@gmail.com>2020-06-26 14:35:41 +0800
commitff4ec5fdb02d22c131e63b5a98e453da975a3cb1 (patch)
treecfe0da78ffbaceff02301478e75c8c94fd6852a9 /configure.ac
parentd5aa783bb282e856478037fe38dd3b8c18f12932 (diff)
downloadlibevent-ff4ec5fdb02d22c131e63b5a98e453da975a3cb1.tar.gz
build: remove duplicate -Wredundant-decls
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2872f865..1903f1c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -873,7 +873,7 @@ if test x$enable_gcc_warnings != xno && test "$GCC" = "yes"; then
#endif])], have_clang=yes, have_clang=no)
# -W is the same as -Wextra
- CFLAGS="$CFLAGS -W -Wfloat-equal -Wundef -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -Wredundant-decls -Wmissing-declarations -Wredundant-decls -Wnested-externs -Wbad-function-cast"
+ CFLAGS="$CFLAGS -W -Wfloat-equal -Wundef -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -Wredundant-decls -Wmissing-declarations -Wnested-externs -Wbad-function-cast"
if test x$enable_gcc_warnings = xyes; then
CFLAGS="$CFLAGS -Werror"
fi