summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNiels Provos <provos@gmail.com>2004-07-30 04:57:21 +0000
committerNiels Provos <provos@gmail.com>2004-07-30 04:57:21 +0000
commit06aaa92fe298e376d432947c6eef9ddabfd5faec (patch)
treed8db7a0beb1af426f3065e845a00e634c054b333 /configure.in
parent6f2f98bd26a04476387e26132fd3ef406b387981 (diff)
downloadlibevent-06aaa92fe298e376d432947c6eef9ddabfd5faec.tar.gz
devpoll support
svn:r113
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index fca0a544..69737297 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@ dnl configure.in for libevent
dnl Dug Song <dugsong@monkey.org>
AC_INIT(event.c)
-AM_INIT_AUTOMAKE(libevent,0.8)
+AM_INIT_AUTOMAKE(libevent,0.9)
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE
@@ -33,7 +33,7 @@ AC_CHECK_LIB(socket, socket)
dnl Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(stdarg.h inttypes.h stdint.h poll.h signal.h unistd.h sys/epoll.h sys/time.h sys/queue.h sys/event.h sys/ioctl.h)
+AC_CHECK_HEADERS(stdarg.h inttypes.h stdint.h poll.h signal.h unistd.h sys/epoll.h sys/time.h sys/queue.h sys/event.h sys/ioctl.h sys/devpoll.h)
if test "x$ac_cv_header_sys_queue_h" = "xyes"; then
AC_MSG_CHECKING(for TAILQ_FOREACH in sys/queue.h)
AC_EGREP_CPP(yes,
@@ -143,6 +143,13 @@ if test "x$haveepoll" = "xyes" ; then
needsignal=yes
fi
+havedevpoll=no
+if test "x$ac_cv_header_sys_devpoll_h" = "xyes"; then
+ AC_DEFINE(HAVE_DEVPOLL, 1,
+ [Define if /dev/poll is available])
+ AC_LIBOBJ(devpoll)
+fi
+
havekqueue=no
if test "x$ac_cv_header_sys_event_h" = "xyes"; then
AC_CHECK_FUNCS(kqueue, [havekqueue=yes], )