summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-09-23 23:51:26 +0000
committerNick Mathewson <nickm@torproject.org>2009-09-23 23:51:26 +0000
commit18fe400805699b6d60bfc26896294a34c6990756 (patch)
treebd0d00e94e46335eb840f5b5b1e21ce8a51fc2ef /configure.in
parent2622e5ace2863e8e869254d9dba86549bbd9159b (diff)
downloadlibevent-18fe400805699b6d60bfc26896294a34c6990756.tar.gz
Forward-port: fix android compilation
svn:r1435
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8b7ed008..977646dd 100644
--- a/configure.in
+++ b/configure.in
@@ -352,6 +352,14 @@ AC_CHECK_TYPES([uint64_t, uint32_t, uint16_t, uint8_t], , ,
#include <sys/types.h>
#endif])
+AC_CHECK_TYPES([fd_mask], , ,
+[#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SELECT_H
+#include <select.h>
+#endif])
+
AC_CHECK_SIZEOF(long long)
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(int)