summaryrefslogtreecommitdiff
path: root/test-export/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test-export/CMakeLists.txt')
-rw-r--r--test-export/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/test-export/CMakeLists.txt b/test-export/CMakeLists.txt
new file mode 100644
index 00000000..53a1cf52
--- /dev/null
+++ b/test-export/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 3.1.2)
+if (POLICY CMP0074)
+ cmake_policy(SET CMP0074 NEW)
+endif()
+project(verify)
+# set(CMAKE_VERBOSE_MAKEFILE 1)
+if(NOT ${EVENT__CODE_COMPONENT} STREQUAL "")
+ string(TOUPPER ${EVENT__CODE_COMPONENT} _UPPER_COMPONENT)
+endif()
+find_package(Libevent 2.1.0 REQUIRED COMPONENTS ${EVENT__LINK_COMPONENT})
+add_definitions(-DEVENT_EXPORT_TEST_COMPONENT_${_UPPER_COMPONENT})
+add_executable(test-export test-export.c)
+target_link_libraries(test-export ${LIBEVENT_LIBRARIES})
+enable_testing()
+add_test(test-export test-export)