summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2012-07-12 20:34:34 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2012-07-12 20:34:34 +0000
commit0c6a5fa0d9719a40748d8726b4543f02f70518c1 (patch)
tree241f9ae619069ac5861d7621ade296102ab5de5d /Makefile.am
downloadlibexif-tarball-0c6a5fa0d9719a40748d8726b4543f02f70518c1.tar.gz
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am54
1 files changed, 54 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ed10b68
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,54 @@
+SUBDIRS = m4m po libexif test doc binary contrib
+
+EXTRA_DIST = @PACKAGE_TARNAME@.spec README-Win32.txt
+
+pkgconfigdir = $(libdir)/pkgconfig
+
+pkgconfig_DATA = libexif.pc
+EXTRA_DIST += libexif.pc.in
+
+noinst_DATA = libexif-uninstalled.pc
+EXTRA_DIST += libexif-uninstalled.pc.in
+
+ACLOCAL_AMFLAGS = -I auto-m4 -I m4m
+
+doc_DATA = README AUTHORS NEWS ChangeLog ABOUT-NLS COPYING
+
+#######################################################################
+# Help for the maintainer
+#
+
+# Simulate something like
+# EXTRA_DIST_IF_EXIST = ChangeLog.cvs
+# If present, ship ChangeLog.cvs in source tarball.
+# If not present, don't ship it.
+dist-hook:
+ if test -f $(srcdir)/ChangeLog.cvs; then \
+ cp -p $(srcdir)/ChangeLog.cvs $(distdir)/ChangeLog.cvs; \
+ fi
+
+.PHONY: cvs-changelog
+cvs-changelog: $(srcdir)/ChangeLog.cvs
+
+.PHONY: $(srcdir)/ChangeLog.cvs
+$(srcdir)/ChangeLog.cvs:
+ if test -f "$(srcdir)/cvs2cl.usermap"; then \
+ usermap="--usermap ./cvs2cl.usermap"; \
+ else \
+ usermap=""; \
+ fi; \
+ (cd "$(srcdir)" && cvs2cl $${usermap} --utc --domain users.sourceforge.net -f "ChangeLog.cvs")
+
+.PHONY: cvs-tag-release
+cvs-tag-release:
+ @tag="$$(echo "$(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-release" | sed 's|\.|_|g')"; \
+ echo "Are you sure you want to CVS tag \`$${tag}' your source files?"; \
+ echo "Press Ctrl-C to abort, Enter to continue."; \
+ read; \
+ cd "$(srcdir)" && cvs tag "$${tag}"
+
+.PHONY: upload-release
+upload-release:
+ echo ncftpput upload.sourceforge.net incoming/ $(PACKAGE_TARNAME)-$(PACKAGE_VERSION).*
+
+# End of Makefile.am.