summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..d0a3551
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,21 @@
+SUBDIRS = nls
+
+# Notes about tests:
+# - Add "small" tests and stuff here.
+# - Add "big" tests and stuff to explicitly test for (fixed) bugs
+# to libexif-testsuite:
+# * We don't want to force people to download dozens of test images
+# just for one small library.
+# * Proper testing is done with the "exif" program in libexif-testsuite.
+# And this is just the lib - we don't have the program available
+# here yet.
+
+TESTS = test-mem test-value test-integers test-parse test-tagtable test-sorted
+
+TEST_IMAGES = $(top_srcdir)/daniel-andrews-sample.jpg
+export TEST_IMAGES
+
+check_PROGRAMS = test-mem test-mnote test-value test-integers test-parse \
+ test-tagtable test-sorted
+
+LDADD = $(top_builddir)/libexif/libexif.la $(LTLIBINTL)