summaryrefslogtreecommitdiff
path: root/expat/configure.ac
diff options
context:
space:
mode:
authorCarlo Bramini <30959007+carlo-bramini@users.noreply.github.com>2022-01-20 21:03:36 +0100
committerGitHub <noreply@github.com>2022-01-20 21:03:36 +0100
commit1e1b52be2d9e1d2e0c3c1cb106eb7c6071747bac (patch)
treeb967e125944477415a5ca0a7f14350e39c24d741 /expat/configure.ac
parent57c7da69b78e3698e112a6b5da19d5109b8232d1 (diff)
downloadlibexpat-git-1e1b52be2d9e1d2e0c3c1cb106eb7c6071747bac.tar.gz
[>=2.3.0] Autotools: Fix broken CMake support under Cygwin (#546)
Autotools: Fix broken CMake support under Cygwin
Diffstat (limited to 'expat/configure.ac')
-rw-r--r--expat/configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/expat/configure.ac b/expat/configure.ac
index c285a2b6..9ce54f1d 100644
--- a/expat/configure.ac
+++ b/expat/configure.ac
@@ -395,9 +395,17 @@ AC_SUBST([AM_CFLAGS])
AC_SUBST([AM_CXXFLAGS])
AC_SUBST([AM_LDFLAGS])
+dnl Emulate the use of CMAKE_SHARED_LIBRARY_PREFIX under CMake
+AC_MSG_CHECKING([for shared library name prefix])
+AS_CASE("${host_os}",
+ [cygwin*], [CMAKE_SHARED_LIBRARY_PREFIX=cyg],
+ [CMAKE_SHARED_LIBRARY_PREFIX=lib])
+AC_MSG_RESULT([${CMAKE_SHARED_LIBRARY_PREFIX}])
+AC_SUBST([CMAKE_SHARED_LIBRARY_PREFIX])
+
AS_CASE("${host_os}",
[darwin*], [CMAKE_NOCONFIG_SOURCE=cmake/autotools/expat-noconfig__macos.cmake.in],
- [mingw*], [CMAKE_NOCONFIG_SOURCE=cmake/autotools/expat-noconfig__windows.cmake.in],
+ [mingw*|cygwin*], [CMAKE_NOCONFIG_SOURCE=cmake/autotools/expat-noconfig__windows.cmake.in],
[CMAKE_NOCONFIG_SOURCE=cmake/autotools/expat-noconfig__linux.cmake.in])
AC_CONFIG_FILES([Makefile]
[expat.pc]