summaryrefslogtreecommitdiff
path: root/expat/configure.ac
diff options
context:
space:
mode:
authorMohammed Khajapasha <mohammed.khajapasha@intel.com>2019-06-19 09:30:47 +0000
committerSebastian Pipping <sebastian@pipping.org>2019-07-03 22:32:34 +0200
commit4a2eb0b7f08c9cb2dbed850462900c7d7a58ec83 (patch)
tree2fb1c77ac523783a70a3065e0996ad93d708f1d2 /expat/configure.ac
parent9c90d3db3a8778d581f3e425f21a0870c0ffd9b5 (diff)
downloadlibexpat-git-4a2eb0b7f08c9cb2dbed850462900c7d7a58ec83.tar.gz
Enable XML_ATTR_INFO in build
enable XML_ATTR_INFO in build to cover XML_ATTR_INFO in CI Signed-off-by: Mohammed Khajapasha <mohammed.khajapasha@intel.com>
Diffstat (limited to 'expat/configure.ac')
-rw-r--r--expat/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/expat/configure.ac b/expat/configure.ac
index 95bdaea1..c9faa191 100644
--- a/expat/configure.ac
+++ b/expat/configure.ac
@@ -222,6 +222,15 @@ AC_DEFINE([XML_DTD], 1,
AC_DEFINE([XML_DEV_URANDOM], 1,
[Define to include code reading entropy from `/dev/urandom'.])
+AC_ARG_ENABLE([xml-attr-info],
+ [AS_HELP_STRING([--enable-xml-attr-info],
+ [Enable retrieving the byte offsets for attribute names and values
+ (default is disabled)])], ,
+ [enable_xml_attr_info=no])
+AS_IF([test "x${enable_xml_attr_info}" = "xyes"],
+ [AC_DEFINE([XML_ATTR_INFO], 1,
+ [Define to allow retrieving the byte offsets for attribute names and values.])])
+
AC_ARG_ENABLE([xml-context],
AS_HELP_STRING([--enable-xml-context @<:@COUNT@:>@],
[Retain context around the current parse point;