summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorgstein <gstein>2001-08-23 12:35:53 +0000
committergstein <gstein>2001-08-23 12:35:53 +0000
commit36b55064c74097ea6b65eac6c4c3e5ef8724c3da (patch)
tree48e130eec088d86a5afb5c2650d260f5b3ec774f /configure.in
parentc05aaf62652f60c1ca3c25ee12e403e79c855cbe (diff)
downloadlibexpat-36b55064c74097ea6b65eac6c4c3e5ef8724c3da.tar.gz
Revamp how the version stuff is handled. Use the header file as the
original, and extract the numbers within the configure script. * configure.in: extract the numbers from lib/expat.h * Makefile.in: simplify the construction of DISTDIR * lib/Makefile.in: no need to define the VERSION preprocessor symbol * lib/expat.dsp: do not define VERSION (changed, but untested!) * lib/xmlparse.c: revamp the XML_ExpatVersion() function * lib/expat.h(.in): just ship the baby, rather than generating it
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 7 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 33d0e8a..def9cd9 100644
--- a/configure.in
+++ b/configure.in
@@ -13,19 +13,12 @@ dnl
AC_INIT(Makefile.in)
AC_CONFIG_AUX_DIR(conftools)
-dnl
-dnl Follow the GNU/Linux convention of odd number minor version for
-dnl beta/development releases and even number minor version for stable
-dnl releases. Edit is bumped with each release and set to 0 with
-dnl change to major or minor version.
-dnl
-
-EXPAT_MAJOR_VERSION=1
-EXPAT_MINOR_VERSION=95
-EXPAT_EDIT=2
+changequote({,})
+EXPAT_MAJOR_VERSION="`sed -n '/MAJOR_VERSION/s/[^0-9]*//gp' lib/expat.h`"
+EXPAT_MINOR_VERSION="`sed -n '/MINOR_VERSION/s/[^0-9]*//gp' lib/expat.h`"
+EXPAT_MICRO_VERSION="`sed -n '/MICRO_VERSION/s/[^0-9]*//gp' lib/expat.h`"
+changequote([,])
-EXPAT_VERSION=$EXPAT_MAJOR_VERSION.$EXPAT_MINOR_VERSION.$EXPAT_EDIT
-VERSION=$EXPAT_VERSION
dnl
dnl Increment LIBREVISION if source code has changed at all
@@ -50,10 +43,9 @@ sinclude(conftools/ac_c_bigendian_cross.m4)
AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
-AC_SUBST(VERSION)
AC_SUBST(EXPAT_MAJOR_VERSION)
AC_SUBST(EXPAT_MINOR_VERSION)
-AC_SUBST(EXPAT_EDIT)
+AC_SUBST(EXPAT_MICRO_VERSION)
AC_SUBST(LIBCURRENT)
AC_SUBST(LIBREVISION)
@@ -102,7 +94,7 @@ dnl this allows this (and the generated configure script) to work
dnl in "embedded distributions", where only part of the Expat sources
dnl are included in the sources for another project.
-OUTPUT="Makefile lib/Makefile lib/expat.h"
+OUTPUT="Makefile lib/Makefile"
if test -d ${srcdir}/xmlwf; then
OUTPUT="$OUTPUT xmlwf/Makefile"
fi