summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfdrake <fdrake>2005-01-28 06:32:30 +0000
committerfdrake <fdrake>2005-01-28 06:32:30 +0000
commita1e760a7cca1b6842e096117fed2f48a9a49d2c4 (patch)
tree2f831a2c23ffc4de5f6d8953362e3ed8b6077f2c /configure.in
parentd1244faa92cf9d048444c58701843d2426adfa53 (diff)
downloadlibexpat-a1e760a7cca1b6842e096117fed2f48a9a49d2c4.tar.gz
implement verbose mode in minicheck to make it easier to determine which
tests failed
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 69e9699..b53e455 100644
--- a/configure.in
+++ b/configure.in
@@ -103,6 +103,38 @@ else
fi
AC_SUBST(FILEMAP)
+dnl Needed for the test support code; this was found at
+dnl http://lists.gnu.org/archive/html/bug-autoconf/2002-07/msg00028.html
+
+# AC_CPP_FUNC
+# ------------------ #
+# Checks to see if ANSI C99 CPP variable __func__ works.
+# If not, perhaps __FUNCTION__ works instead.
+# If not, we'll just define __func__ to "".
+AC_DEFUN([AC_CPP_FUNC],
+[AC_REQUIRE([AC_PROG_CC_STDC])dnl
+AC_CACHE_CHECK([for an ANSI C99-conforming __func__], ac_cv_cpp_func,
+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],
+[[char *foo = __func__;]])],
+ [ac_cv_cpp_func=yes],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],
+[[char *foo = __FUNCTION__;]])],
+ [ac_cv_cpp_func=__FUNCTION__],
+ [ac_cv_cpp_func=no])])])
+if test $ac_cv_cpp_func = __FUNCTION__; then
+ AC_DEFINE(__func__,__FUNCTION__,
+ [Define to __FUNCTION__ or "" if `__func__' does not conform to
+ANSI C.])
+elif test $ac_cv_cpp_func = no; then
+ AC_DEFINE(__func__,"",
+ [Define to __FUNCTION__ or "" if `__func__' does not conform to
+ANSI C.])
+fi
+])# AC_CPP_FUNC
+
+AC_CPP_FUNC
+
+
dnl Some basic configuration:
AC_DEFINE([XML_NS], 1,
[Define to make XML Namespaces functionality available.])