summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am23
1 files changed, 0 insertions, 23 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
deleted file mode 100644
index 6bcf27c..0000000
--- a/test/Makefile.am
+++ /dev/null
@@ -1,23 +0,0 @@
-AM_CFLAGS =-DFAKE_SLEEP -DFAKE_INTERNAL_CALLS -I../ -I../src
-
-AM_LDFLAGS =
-
-bin_PROGRAMS = timetest
-timetest_SOURCES = timetest.c
-
-if SOLARIS
- AM_CFLAGS += -D__EXTENSIONS__ -D_XOPEN_SOURCE=600
- AM_LDFLAGS += -Wl,--version-script=libfaketime.map
-endif
-if !MACOS
- AM_CFLAGS += -std=gnu99 -Wall -Wextra -Werror -DFAKE_STAT -DFAKE_PTHREAD -DFAKE_TIMERS -DFAKE_INTERNAL_CALLS -fPIC -Wno-nonnull-compare
- timetest_LDADD = -ldl -lm -lrt -lpthread
-endif
-
-test: timetest functest
- @echo
- @./test.sh
-#
-# run functional tests
-functest:
- ./testframe.sh functests