summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony Green <green@moxielogic.com>2013-07-02 12:12:34 -0700
committerAnthony Green <green@moxielogic.com>2013-07-02 12:12:34 -0700
commit6a4d901dde7b3f87984c563505717cde3113d16e (patch)
tree904ebf068fb1ceae4d76398af92140e6f5508568 /configure.ac
parentb50a13b9c07ec09af4b9697e482acdad571e6961 (diff)
parent587002c092cffe6e7a8d7028f246c241d03b738c (diff)
downloadlibffi-6a4d901dde7b3f87984c563505717cde3113d16e.tar.gz
Merge pull request #36 from abergmeier/emscripten_fix
Fixes for building with Emscripten
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a26cb46..a46a514 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,7 +33,6 @@ AC_SUBST(CFLAGS)
AM_PROG_AS
AM_PROG_CC_C_O
-AC_PROG_LIBTOOL
AC_CONFIG_MACRO_DIR([m4])
# Test for 64-bit build.
@@ -539,6 +538,14 @@ AC_ARG_ENABLE(purify-safety,
if test "$enable_purify_safety" = "yes"; then
AC_DEFINE(USING_PURIFY, 1, [Define this if you are using Purify and want to suppress spurious messages.])
fi)
+
+AC_ARG_ENABLE(libtool,
+[ --disable-libtool do not use libtool to handle libraries])
+AM_CONDITIONAL(USE_LIBTOOL, !test "x$enable_libtool" = "xno")
+
+if test "x$enable_libtool" = "xyes"; then
+AC_PROG_LIBTOOL
+fi
# These variables are only ever used when we cross-build to X86_WIN32.
# And we only support this with GCC, so...