summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Ralls <jralls@ceridwen.us>2013-01-26 15:21:14 -0800
committerJohn Ralls <jralls@ceridwen.us>2013-01-26 15:26:01 -0800
commitbcc0c28001b6d427d5cd8037d2e3c892babc6b4c (patch)
treeda9369db4eaff0af78ab4a418cb49d0b99dfb771 /configure.ac
parentbada2e326d9a9acf3ae40cfa4f5d7a9ba97b2ea8 (diff)
downloadlibffi-bcc0c28001b6d427d5cd8037d2e3c892babc6b4c.tar.gz
Reorder x86_64 tests
So that darwin and cygwin/mingw are tested before the generic check -- which allows them to actually be set.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 17 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 5d61007..e25b6e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,6 +146,23 @@ case "$host" in
fi
;;
+ x86_64-*-darwin*)
+ TARGET=X86_DARWIN; TARGETDIR=x86
+ ;;
+
+ x86_64-*-cygwin* | x86_64-*-mingw*)
+ TARGET=X86_WIN64; TARGETDIR=x86
+ # All mingw/cygwin/win32 builds require -no-undefined for sharedlib.
+ # We must also check with_cross_host to decide if this is a native
+ # or cross-build and select where to install dlls appropriately.
+ if test -n "$with_cross_host" &&
+ test x"$with_cross_host" != x"no"; then
+ AM_LTLDFLAGS='-no-undefined -bindir "$(toolexeclibdir)"';
+ else
+ AM_LTLDFLAGS='-no-undefined -bindir "$(bindir)"';
+ fi
+ ;;
+
i?86-*-* | x86_64-*-*)
TARGETDIR=x86
if test $ac_cv_sizeof_size_t = 4; then
@@ -224,23 +241,6 @@ case "$host" in
TARGET=TILE; TARGETDIR=tile
;;
- x86_64-*-darwin*)
- TARGET=X86_DARWIN; TARGETDIR=x86
- ;;
-
- x86_64-*-cygwin* | x86_64-*-mingw*)
- TARGET=X86_WIN64; TARGETDIR=x86
- # All mingw/cygwin/win32 builds require -no-undefined for sharedlib.
- # We must also check with_cross_host to decide if this is a native
- # or cross-build and select where to install dlls appropriately.
- if test -n "$with_cross_host" &&
- test x"$with_cross_host" != x"no"; then
- AM_LTLDFLAGS='-no-undefined -bindir "$(toolexeclibdir)"';
- else
- AM_LTLDFLAGS='-no-undefined -bindir "$(bindir)"';
- fi
- ;;
-
xtensa*-*)
TARGET=XTENSA; TARGETDIR=xtensa
;;