summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Triplett <josh@joshtriplett.org>2014-03-24 21:44:13 -0700
committerJosh Triplett <josh@joshtriplett.org>2014-03-24 21:45:47 -0700
commitbe50b87a490e794362cb4a27ada2fbaab202adb8 (patch)
treec0ffa4c0da4f81bbabb11eed6009a7630f99b827 /configure.ac
parentf0f4138f90345d7d67dfa6783a7e1c7cc30d3c6f (diff)
downloadlibffi-be50b87a490e794362cb4a27ada2fbaab202adb8.tar.gz
Always use configure to detect whether global symbols need underscores
64-bit Windows already used this check; make it universal, and use it in place of an ifdef on X86_WIN32, to handle non-Windows platforms that use the underscore, such as Darwin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 3169c43..ffcdd49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -439,11 +439,9 @@ AC_ARG_ENABLE(pax_emutramp,
[Define this if you want to enable pax emulated trampolines])
fi)
-if test x$TARGET = xX86_WIN64; then
- LT_SYS_SYMBOL_USCORE
- if test "x$sys_symbol_underscore" = xyes; then
- AC_DEFINE(SYMBOL_UNDERSCORE, 1, [Define if symbols are underscored.])
- fi
+LT_SYS_SYMBOL_USCORE
+if test "x$sys_symbol_underscore" = xyes; then
+ AC_DEFINE(SYMBOL_UNDERSCORE, 1, [Define if symbols are underscored.])
fi
FFI_EXEC_TRAMPOLINE_TABLE=0