summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorAnthony Green <green@moxielogic.com>2009-10-04 08:11:33 -0400
committerAnthony Green <green@moxielogic.com>2009-10-04 08:11:33 -0400
commitc6dddbd02bad9654ed58cdb0feb360934d105dec (patch)
treeeac77260c97ba28f2869ec738dedc0e68745de1a /include/Makefile.am
downloadlibffi-c6dddbd02bad9654ed58cdb0feb360934d105dec.tar.gz
Initial commit
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
new file mode 100644
index 0000000..f11151e
--- /dev/null
+++ b/include/Makefile.am
@@ -0,0 +1,12 @@
+## Process this with automake to create Makefile.in
+
+AUTOMAKE_OPTIONS=foreign
+
+DISTCLEANFILES=ffitarget.h
+EXTRA_DIST=ffi.h.in ffi_common.h
+
+# Where generated headers like ffitarget.h get installed.
+gcc_version := $(shell cat $(top_srcdir)/../gcc/BASE-VER)
+toollibffidir := $(libdir)/gcc/$(target_alias)/$(gcc_version)/include
+
+toollibffi_HEADERS = ffi.h ffitarget.h