summaryrefslogtreecommitdiff
path: root/.pc/x86_pcrel_test/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '.pc/x86_pcrel_test/configure.ac')
-rw-r--r--.pc/x86_pcrel_test/configure.ac16
1 files changed, 5 insertions, 11 deletions
diff --git a/.pc/x86_pcrel_test/configure.ac b/.pc/x86_pcrel_test/configure.ac
index 66a4942..d12375d 100644
--- a/.pc/x86_pcrel_test/configure.ac
+++ b/.pc/x86_pcrel_test/configure.ac
@@ -131,6 +131,10 @@ case "$host" in
TARGET=MIPS; TARGETDIR=mips
;;
+ moxie-*-*)
+ TARGET=MOXIE; TARGETDIR=moxie
+ ;;
+
powerpc*-*-linux* | powerpc-*-sysv*)
TARGET=POWERPC; TARGETDIR=powerpc
;;
@@ -237,17 +241,7 @@ AC_SUBST(HAVE_LONG_DOUBLE)
AC_C_BIGENDIAN
-AC_CACHE_CHECK([assembler .cfi pseudo-op support],
- libffi_cv_as_cfi_pseudo_op, [
- libffi_cv_as_cfi_pseudo_op=unknown
- AC_TRY_COMPILE([asm (".cfi_startproc\n\t.cfi_endproc");],,
- [libffi_cv_as_cfi_pseudo_op=yes],
- [libffi_cv_as_cfi_pseudo_op=no])
-])
-if test "x$libffi_cv_as_cfi_pseudo_op" = xyes; then
- AC_DEFINE(HAVE_AS_CFI_PSEUDO_OP, 1,
- [Define if your assembler supports .cfi_* directives.])
-fi
+GCC_AS_CFI_PSEUDO_OP
if test x$TARGET = xSPARC; then
AC_CACHE_CHECK([assembler and linker support unaligned pc related relocs],