summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f59e89..29eee3e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,11 +38,21 @@ endif()
add_library(libflang ${libkind} lib/Libflang.cpp
lib/Core/Core.cpp
lib/Numerical/Complex.cpp
+ lib/Numerical/Integer.cpp
lib/Strings/Character.cpp
lib/IO/Write.cpp
lib/System/System.cpp
)
+# Tests
+
+macro(add_libflang_test name)
+ add_executable( ${name} ${ARGN} )
+ target_link_libraries( ${name} libflang )
+endmacro(add_libflang_test)
+
+add_subdirectory(test)
+
set(BUG_REPORT_URL "http://llvm.org/bugs/" CACHE STRING
"Default URL where bug reports are to be submitted.")