summaryrefslogtreecommitdiff
path: root/cipher/Makefile.am
diff options
context:
space:
mode:
authorTianjia Zhang <tianjia.zhang@linux.alibaba.com>2020-01-20 11:42:24 +0800
committerNIIBE Yutaka <gniibe@fsij.org>2020-01-21 13:39:49 +0900
commit6b55246c77089dd372eb1807808111660fd789c7 (patch)
tree3d49f07265f04b0c2682517167ce3f16421c6717 /cipher/Makefile.am
parent8d9958910e54f3fecbab6e133c3971843f6ef310 (diff)
downloadlibgcrypt-6b55246c77089dd372eb1807808111660fd789c7.tar.gz
Add elliptic curve SM2 implementation.
* configure.ac (enabled_pubkey_ciphers): Add ecc-sm2. * cipher/Makefile.am (EXTRA_libcipher_la_SOURCES): Add ecc-sm2.c. * cipher/pubkey-util.c (_gcry_pk_util_parse_flaglist, _gcry_pk_util_preparse_sigval): Add sm2 flags. * cipher/ecc.c: Support ecc-sm2. * cipher/ecc-common.h: Add declarations for ecc-sm2. * cipher/ecc-sm2.c: New. * src/cipher.h: Define PUBKEY_FLAG_SM2. -- Signed-off-by: Tianjia Zhang <tianjia.zhang@linux.alibaba.com>
Diffstat (limited to 'cipher/Makefile.am')
-rw-r--r--cipher/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cipher/Makefile.am b/cipher/Makefile.am
index 020a9616..10a5ab62 100644
--- a/cipher/Makefile.am
+++ b/cipher/Makefile.am
@@ -87,7 +87,7 @@ EXTRA_libcipher_la_SOURCES = \
dsa.c \
elgamal.c \
ecc.c ecc-curves.c ecc-misc.c ecc-common.h \
- ecc-ecdh.c ecc-ecdsa.c ecc-eddsa.c ecc-gost.c \
+ ecc-ecdh.c ecc-ecdsa.c ecc-eddsa.c ecc-gost.c ecc-sm2.c \
idea.c \
gost28147.c gost.h \
gostr3411-94.c \