summaryrefslogtreecommitdiff
path: root/cipher/Makefile.am
diff options
context:
space:
mode:
authorDanny Tsen <dtsen@us.ibm.com>2022-06-12 21:30:19 +0300
committerJussi Kivilinna <jussi.kivilinna@iki.fi>2022-06-12 22:02:48 +0300
commit88fe7ac33eb4cb4dff76a5cc7fca50da5fb0ee3a (patch)
tree395a466d420dab91a5f82c98bbe44f0f78bb4fb0 /cipher/Makefile.am
parent6d32bf80846a22568575a101a3fe6769ab058bb9 (diff)
downloadlibgcrypt-88fe7ac33eb4cb4dff76a5cc7fca50da5fb0ee3a.tar.gz
Chacha20/poly1305 - Optimized chacha20/poly1305 for P10 operation
* configure.ac: Added chacha20 and poly1305 assembly implementations. * cipher/chacha20-p10le-8x.s: (New) - support 8 blocks (512 bytes) unrolling. * cipher/poly1305-p10le.s: (New) - support 4 blocks (128 bytes) unrolling. * cipher/Makefile.am: Added new chacha20 and poly1305 files. * cipher/chacha20.c: Added PPC p10 le support for 8x chacha20. * cipher/poly1305.c: Added PPC p10 le support for 4x poly1305. * cipher/poly1305-internal.h: Added PPC p10 le support for poly1305. --- GnuPG-bug-id: 6006 Signed-off-by: Danny Tsen <dtsen@us.ibm.com> [jk: cosmetic changes to C code] [jk: fix building on ppc64be] Signed-off-by: Jussi Kivilinna <jussi.kivilinna@iki.fi>
Diffstat (limited to 'cipher/Makefile.am')
-rw-r--r--cipher/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cipher/Makefile.am b/cipher/Makefile.am
index 250b229e..6230d52e 100644
--- a/cipher/Makefile.am
+++ b/cipher/Makefile.am
@@ -82,6 +82,7 @@ EXTRA_libcipher_la_SOURCES = \
chacha20.c chacha20-amd64-ssse3.S chacha20-amd64-avx2.S \
chacha20-amd64-avx512.S chacha20-armv7-neon.S chacha20-aarch64.S \
chacha20-ppc.c chacha20-s390x.S \
+ chacha20-p10le-8x.s \
cipher-gcm-ppc.c cipher-gcm-intel-pclmul.c cipher-gcm-armv7-neon.S \
cipher-gcm-armv8-aarch32-ce.S cipher-gcm-armv8-aarch64-ce.S \
crc.c crc-intel-pclmul.c crc-armv8-ce.c \
@@ -98,6 +99,7 @@ EXTRA_libcipher_la_SOURCES = \
md4.c \
md5.c \
poly1305-s390x.S poly1305-amd64-avx512.S \
+ poly1305-p10le.s \
rijndael.c rijndael-internal.h rijndael-tables.h \
rijndael-aesni.c rijndael-padlock.c \
rijndael-amd64.S rijndael-arm.S \