summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJussi Kivilinna <jussi.kivilinna@iki.fi>2022-09-25 22:23:22 +0300
committerJussi Kivilinna <jussi.kivilinna@iki.fi>2022-09-27 08:30:45 +0300
commit0cb29a5736cfcd6bce4ce2495cd0481f0bdb34a4 (patch)
tree5f9a858bec394b6aebbdf9830cb0bbce88d34147 /configure.ac
parent9c828129b2058c3f36e07634637929a54e8377ee (diff)
downloadlibgcrypt-0cb29a5736cfcd6bce4ce2495cd0481f0bdb34a4.tar.gz
tests/hashtest: add hugeblock & disable-hwf options and 6 gig test vectors
* .gitignore: Add 'tests/hashtest-6g'. * configure.ac: Add 'tests/hashtest-6g'. * tests/Makefile: Add 'hashtest-6g'. * tests/hashtest-6g.in: New. * tests/hashtest-256g.in: Add SHA3-512 to algos. * tests/hashtest.c (use_hugeblock): New. (testvectors): Add 256 GiB test vectors for BLAKE2S, BLAKE2B and whirlpool; Add 6 GiB test vectors for SHA1, SHA256, SHA512, SHA3, SM3, BLAKE2S, BLAKE2B, WHIRLPOOL, CRC32 and CRC24. (run_longtest); Use huge 5 GiB pattern block when requested. (main): Add '--hugeblock' and '--disable-hwf' options. * tests/testdrv.c: Add 'hashtest-6g'; Add SHA3 to 'hashtest-256g'. -- GnuPG-bug-id: 6217 Signed-off-by: Jussi Kivilinna <jussi.kivilinna@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c8f24dcc..c39257b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3511,6 +3511,7 @@ src/libgcrypt.pc
src/versioninfo.rc
tests/Makefile
])
+AC_CONFIG_FILES([tests/hashtest-6g], [chmod +x tests/hashtest-6g])
AC_CONFIG_FILES([tests/hashtest-256g], [chmod +x tests/hashtest-256g])
AC_CONFIG_FILES([tests/basic-disable-all-hwf], [chmod +x tests/basic-disable-all-hwf])
AC_OUTPUT