summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2021-12-17 09:42:48 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2021-12-17 09:42:48 +0900
commit27d945084f6926d0ebe8066fb60db785f3a8fb57 (patch)
tree5cc62ca266375427eaf6701b7de55258f6baa4e2 /configure.ac
parent14f5d73e2731b83b18e9771eb3068c6dbba6f069 (diff)
downloadlibgcrypt-27d945084f6926d0ebe8066fb60db785f3a8fb57.tar.gz
random: Keep --enable-random-daemon, but not its use from runtime.
* configure.ac (--enable-random-daemon): Don't define USE_RANDOM_DAEMON, but use the conditional ENABLE_RANDOM_DAEMON. * src/Makefile.am: Use the conditional ENABLE_RANDOM_DAEMON. -- GnuPG-bug-id: 5706 Fixes-commit: 754ad5815b5bb7462260414f2bc5f449bee0b1c6 Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 51a81210..e8ef8378 100644
--- a/configure.ac
+++ b/configure.ac
@@ -528,14 +528,10 @@ AC_MSG_CHECKING([whether the experimental random daemon is requested])
AC_ARG_ENABLE([random-daemon],
AS_HELP_STRING([--enable-random-daemon],
[Build the experimental gcryptrnd]),
- [use_random_daemon=$enableval],
- [use_random_daemon=no])
-AC_MSG_RESULT($use_random_daemon)
-if test x$use_random_daemon = xyes ; then
- AC_DEFINE(USE_RANDOM_DAEMON,1,
- [Define to support the experimental random daemon])
-fi
-AM_CONDITIONAL(USE_RANDOM_DAEMON, test x$use_random_daemon = xyes)
+ [enable_random_daemon=$enableval],
+ [enable_random_daemon=no])
+AC_MSG_RESULT($enable_random_daemon)
+AM_CONDITIONAL(ENABLE_RANDOM_DAEMON, test x$enable_random_daemon = xyes)
# Implementation of --disable-asm.
@@ -799,7 +795,7 @@ AC_ARG_WITH(pth-prefix,
if test x$pth_config_prefix != x ; then
PTH_CONFIG="$pth_config_prefix/bin/pth-config"
fi
-if test "$use_random_daemon" = "yes"; then
+if test "$enable_random_daemon" = "yes"; then
AC_PATH_PROG(PTH_CONFIG, pth-config, no)
if test "$PTH_CONFIG" = "no"; then
AC_MSG_WARN([[