summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2002-09-17 12:41:31 +0000
committerWerner Koch <wk@gnupg.org>2002-09-17 12:41:31 +0000
commit9f66d05caee37150c39e6aaf9ab1639a47b02919 (patch)
treec7c302f460c86a75b762f3390a839d4379645181 /configure.ac
parentc2fa23b3f0a1fcaa3fe511c97e17ff20f32b6689 (diff)
downloadlibgcrypt-9f66d05caee37150c39e6aaf9ab1639a47b02919.tar.gz
* configure.ac: Check for Pth and Pthreads.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 20 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6aacb4eb..1b0bf5d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -384,9 +384,26 @@ AC_CHECK_FUNCS(waitpid wait4 sigaction sigprocmask fopen64 fstat64)
GNUPG_CHECK_MLOCK
GNUPG_FUNC_MKDIR_TAKES_ONE_ARG
-dnl
-dnl Check whether we can use Linux capabilities as requested
-dnl
+#
+# The ATH systems needs to know whether pth or pthreads are available.
+#
+have_pth=no
+have_pthread=no
+AC_CHECK_LIB(pth,pth_version,have_pth=yes)
+if test "$have_pth" = yes; then
+ AC_DEFINE(HAVE_PTH, ,[Define if we have Pth.])
+fi
+AC_CHECK_LIB(pthread,pthread_create,have_pthread=yes)
+if test "$have_pthread" = yes; then
+ AC_DEFINE(HAVE_PTHREAD, ,[Define if we have pthread.])
+fi
+AM_CONDITIONAL(HAVE_PTH, test "$have_pth" = "yes")
+AM_CONDITIONAL(HAVE_PTHREAD, test "$have_pthread" = "yes")
+
+
+#
+# Check whether we can use Linux capabilities as requested
+#
if test "$use_capabilities" = "yes" ; then
use_capabilities=no
AC_CHECK_HEADERS(sys/capability.h)