summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Jelen <jjelen@redhat.com>2021-09-17 17:11:30 +0200
committerWerner Koch <wk@gnupg.org>2021-09-20 08:32:29 +0200
commitc74fde0c3f6114c594332fb28a09c7b817969231 (patch)
treed99d2ef502cf4027a7a23ef05b51060b664d84c6 /configure.ac
parent3f4dd47ba74e0a9f18feba1809eeddff8790707e (diff)
downloadlibgcrypt-c74fde0c3f6114c594332fb28a09c7b817969231.tar.gz
Allow passing FIPS module version
* README: Document new --with-fips-module-version=version switch * configure.ac: Implementation of the --with-fips-module-version * src/global.c (print_config): Print FIPS module version from above -- Signed-off-by: Jakub Jelen <jjelen@redhat.com> Moved the module version to a 3rd field to keep the semantics of that line. Signed-off-by: Werner Koch <wk@gnupg.org> GnuPG-bug-id: 1600
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index adf5ebf6..e31c7905 100644
--- a/configure.ac
+++ b/configure.ac
@@ -604,6 +604,12 @@ if test "$use_hmac_binary_check" = yes ; then
fi
AM_CONDITIONAL(USE_HMAC_BINARY_CHECK, test x$use_hmac_binary_check = xyes)
+# Implementation of the --with-fips-module-version.
+AC_ARG_WITH(fips-module-version,
+ [ --with-fips-module-version=VERSION)],
+ fips_module_version="$withval", fips_module_version="" )
+AC_DEFINE_UNQUOTED(FIPS_MODULE_VERSION, "$fips_module_version",
+ [Define FIPS module version for certification])
# Implementation of the --disable-jent-support switch.
AC_MSG_CHECKING([whether jitter entropy support is requested])
@@ -3271,6 +3277,7 @@ GCRY_MSG_WRAP([Enabled pubkey algorithms:],[$enabled_pubkey_ciphers])
GCRY_MSG_SHOW([Random number generator: ],[$random])
GCRY_MSG_SHOW([Try using jitter entropy: ],[$jentsupport])
GCRY_MSG_SHOW([Using linux capabilities: ],[$use_capabilities])
+GCRY_MSG_SHOW([FIPS module version: ],[$fips_module_version])
GCRY_MSG_SHOW([Try using Padlock crypto: ],[$padlocksupport])
GCRY_MSG_SHOW([Try using AES-NI crypto: ],[$aesnisupport])
GCRY_MSG_SHOW([Try using Intel SHAEXT: ],[$shaextsupport])