summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2022-02-15 09:19:28 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2022-02-16 11:14:34 +0900
commitd98a78f0eb7711d32f473a04ea417e0f0bde6a00 (patch)
tree545d281b370c28c71603e7e1298fdc0947449e84 /configure.ac
parent521500624b4b11538d206137205e2a511dad7072 (diff)
downloadlibgcrypt-d98a78f0eb7711d32f473a04ea417e0f0bde6a00.tar.gz
build: Remove checking Pth library.
* acinclude.m4 (GNUPG_PTH_VERSION_CHECK): Remove. * configure.ac (PTH_CFLAGS, PTH_LIBS): Remove. -- Fixes-commit: d918d8aee27987c3bb99f44a7ed3508d81009f51 Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index a9350c9c..f0f1637f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -766,44 +766,6 @@ AC_DEFINE(GPG_ERR_SOURCE_DEFAULT, GPG_ERR_SOURCE_GCRYPT,
[The default error source for libgcrypt.])
#
-# Check whether the GNU Pth library is available. We require this
-# to build the optional gcryptrnd program.
-#
-AC_ARG_WITH(pth-prefix,
- AS_HELP_STRING([--with-pth-prefix=PFX],
- [prefix where GNU Pth is installed (optional)]),
- pth_config_prefix="$withval", pth_config_prefix="")
-if test x$pth_config_prefix != x ; then
- PTH_CONFIG="$pth_config_prefix/bin/pth-config"
-fi
-if test "$enable_random_daemon" = "yes"; then
- AC_PATH_PROG(PTH_CONFIG, pth-config, no)
- if test "$PTH_CONFIG" = "no"; then
- AC_MSG_WARN([[
-***
-*** To build the Libgcrypt's random number daemon
-*** we need the support of the GNU Portable Threads Library.
-*** Download it from ftp://ftp.gnu.org/gnu/pth/
-*** On a Debian GNU/Linux system you might want to try
-*** apt-get install libpth-dev
-***]])
- else
- GNUPG_PTH_VERSION_CHECK([1.3.7])
- if test $have_pth = yes; then
- PTH_CFLAGS=`$PTH_CONFIG --cflags`
- PTH_LIBS=`$PTH_CONFIG --ldflags`
- PTH_LIBS="$PTH_LIBS `$PTH_CONFIG --libs --all`"
- AC_DEFINE(USE_GNU_PTH, 1,
- [Defined if the GNU Portable Thread Library should be used])
- AC_DEFINE(HAVE_PTH, 1,
- [Defined if the GNU Pth is available])
- fi
- fi
-fi
-AC_SUBST(PTH_CFLAGS)
-AC_SUBST(PTH_LIBS)
-
-#
# Check whether pthreads is available
#
if test "$have_w32_system" != yes; then