summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2003-11-04 12:02:42 +0000
committerWerner Koch <wk@gnupg.org>2003-11-04 12:02:42 +0000
commitf13d7964c639dffa8ec9b77cc211fe83a4c9d6bc (patch)
tree2ff7eef94fe321c93d1470fc376d0e2ba4fb3f46 /configure.ac
parentbab587c2814ebdce5917bc8db10b84ec0daea9c3 (diff)
downloadlibgcrypt-f13d7964c639dffa8ec9b77cc211fe83a4c9d6bc.tar.gz
(USE_SHA1): Make sure it is always included.
(USE_RMD160): Removed this AM conditional.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 67e738c8..f5172987 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@ AC_PREREQ(2.52)
# but remove a "-cvs" prefix right *before* a release and append it
# soon later.
-AC_INIT(libgcrypt, 1.1.44, bug-libgcrypt@gnupg.org)
+AC_INIT(libgcrypt, 1.1.90-cvs, bug-libgcrypt@gnupg.org)
# LT Version numbers, remember to change them just *before* a release.
# (Interfaces removed: CURRENT++, AGE=0, REVISION=0)
@@ -741,11 +741,6 @@ test "$found" = "1" && GCRYPT_DIGESTS="$GCRYPT_DIGESTS md5.lo"
AC_DEFINE_UNQUOTED(USE_MD5, $found,
[Defined if this module should be included])
-LIST_MEMBER(sha1, $enabled_digests)
-test "$found" = "1" && GCRYPT_DIGESTS="$GCRYPT_DIGESTS sha1.lo"
-AC_DEFINE_UNQUOTED(USE_SHA1, $found,
- [Defined if this module should be included])
-
LIST_MEMBER(sha256, $enabled_digests)
test "$found" = "1" && GCRYPT_DIGESTS="$GCRYPT_DIGESTS sha256.lo"
AC_DEFINE_UNQUOTED(USE_SHA256, $found,
@@ -761,10 +756,10 @@ test "$found" = "1" && GCRYPT_DIGESTS="$GCRYPT_DIGESTS tiger.lo"
AC_DEFINE_UNQUOTED(USE_TIGER, $found,
[Defined if this module should be included])
-# rmd160 should be included always.
-GCRYPT_DIGESTS="$GCRYPT_DIGESTS rmd160.lo"
-AM_CONDITIONAL(USE_RMD160, true)
+# rmd160 and sha1 should be included always.
+GCRYPT_DIGESTS="$GCRYPT_DIGESTS rmd160.lo sha1.lo"
AC_DEFINE_UNQUOTED(USE_RMD160, 1, [Defined if this module should be included])
+AC_DEFINE_UNQUOTED(USE_SHA1, 1, [Defined if this module should be included])
LIST_MEMBER(linux, $random_modules)
test "$found" = "1" && GCRYPT_RANDOM="$GCRYPT_RANDOM rndlinux.lo"