summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2022-02-10 09:44:41 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2022-02-10 09:44:41 +0900
commitf98ca6aa34ccdbbaf94f93ae30beafe400303c97 (patch)
tree1e4c6b251a57545c5e3b06425332a23d72de255d /configure.ac
parent90f41a1898e421c04080d35d7fea98ee18e74865 (diff)
downloadlibgcrypt-f98ca6aa34ccdbbaf94f93ae30beafe400303c97.tar.gz
Remove the built-in memory guard support.
* configure.ac (--enable-m-guard): Remove. * src/global.c (_gcry_vcontrol): Return GPG_ERR_NOT_SUPPORTED for GCRYCTL_ENABLE_M_GUARD. * src/stdmem.c (use_m_guard, _gcry_private_enable_m_guard): Remove. (_gcry_private_malloc): Remove the code path with use_m_guard==1. (_gcry_private_malloc_secure): Likewise. (_gcry_private_realloc, _gcry_private_free): Likewise. (_gcry_private_check_heap): Remove. * src/stdmem.h: Remove declarations for memory guard functions. -- GnuPG-bug-id: T5822 Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 0667484e..a9350c9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -363,8 +363,6 @@ AC_CHECK_SIZEOF(unsigned long, 4)
AC_CHECK_SIZEOF(unsigned long long, 0)
AC_CHECK_SIZEOF(void *, 0)
-AC_CHECK_ALIGNOF(long double)
-
AC_TYPE_UINTPTR_T
if test "$ac_cv_sizeof_unsigned_short" = "0" \
@@ -539,17 +537,6 @@ if test "$try_asm_modules" != yes ; then
AC_DEFINE(ASM_DISABLED,1,[Defined if --disable-asm was used to configure])
fi
-# Implementation of the --enable-m-guard switch.
-AC_MSG_CHECKING([whether memory guard is requested])
-AC_ARG_ENABLE(m-guard,
- AS_HELP_STRING([--enable-m-guard],
- [Enable memory guard facility]),
- [use_m_guard=$enableval], [use_m_guard=no])
-AC_MSG_RESULT($use_m_guard)
-if test "$use_m_guard" = yes ; then
- AC_DEFINE(M_GUARD,1,[Define to use the (obsolete) malloc guarding feature])
-fi
-
# Implementation of the --enable-large-data-tests switch.
AC_MSG_CHECKING([whether to run large data tests])
AC_ARG_ENABLE(large-data-tests,