summaryrefslogtreecommitdiff
path: root/random/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2008-07-05 16:44:03 +0000
committerWerner Koch <wk@gnupg.org>2008-07-05 16:44:03 +0000
commitb43501cc3f5b760da701e48a48e00634ad06e461 (patch)
treedd6713ea5e42bb805074010c7bc4797d5153ffdc /random/Makefile.am
parent40e1ff89408eaeb56d32068bc9c9551715f2deff (diff)
downloadlibgcrypt-b43501cc3f5b760da701e48a48e00634ad06e461.tar.gz
Moved random stuff into its own directory.
Diffstat (limited to 'random/Makefile.am')
-rw-r--r--random/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/random/Makefile.am b/random/Makefile.am
new file mode 100644
index 00000000..b5a7c457
--- /dev/null
+++ b/random/Makefile.am
@@ -0,0 +1,47 @@
+# Makefile for cipher modules
+# Copyright (C) 2008 Free Software Foundation, Inc.
+#
+# This file is part of Libgcrypt.
+#
+# Libgcrypt is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of
+# the License, or (at your option) any later version.
+#
+# Libgcrypt is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+# Process this file with automake to produce Makefile.in
+
+# Need to include ../src in addition to top_srcdir because gcrypt.h is
+# a built header.
+AM_CPPFLAGS = -I../src -I$(top_srcdir)/src
+AM_CFLAGS = $(GPG_ERROR_CFLAGS)
+
+noinst_LTLIBRARIES = librandom.la
+
+GCRYPT_MODULES = @GCRYPT_RANDOM@
+
+librandom_la_DEPENDENCIES = $(GCRYPT_MODULES)
+librandom_la_LIBADD = $(GCRYPT_MODULES)
+
+librandom_la_SOURCES = \
+random.c random.h \
+rndhw.c \
+rand-internal.h
+
+if USE_RANDOM_DAEMON
+librandom_la_SOURCES += random-daemon.c
+endif USE_RANDOM_DAEMON
+
+
+EXTRA_librandom_la_SOURCES = \
+rndlinux.c \
+rndegd.c \
+rndunix.c \
+rndw32.c