summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2021-08-19 10:48:55 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2021-08-19 10:48:55 +0900
commit24aaded244a2b9427f2e90e4bf7adf086e0e0fef (patch)
tree3e8ef96cdef55844370a5bccde6ff74f180aa548 /src/Makefile.am
parent3c89aad4a0d7f836fd747d4e2f0edfbf648ae318 (diff)
downloadlibgcrypt-24aaded244a2b9427f2e90e4bf7adf086e0e0fef.tar.gz
build: Generate hash for integrity check with hmac256 (2).
* src/Makefile.am (libgcrypt.la.done): Use the rodata1 section. * src/fips.c (_gcry_fips_run_selftests): Only enable check_binary_integrity by ENABLE_HMAC_BINARY_CHECK. [ENABLE_HMAC_BINARY_CHECK] (hmac_for_the_implementation): New. [ENABLE_HMAC_BINARY_CHECK] (check_binary_integrity): Use hmac_for_the_implementation in rodata. -- GnuPG-bug-id: 5550 Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0ac58ac4..12568fd8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -154,9 +154,8 @@ if USE_HMAC_BINARY_CHECK
CLEANFILES += libgcrypt.so.hmac
libgcrypt.la.done: libgcrypt.so.hmac
- $(OBJCOPY) --add-section .hmac=libgcrypt.so.hmac \
- --set-section-flags .hmac=noload,readonly .libs/libgcrypt.so \
- .libs/libgcrypt.so.new
+ $(OBJCOPY) --update-section .rodata1=libgcrypt.so.hmac \
+ .libs/libgcrypt.so .libs/libgcrypt.so.new
mv -f .libs/libgcrypt.so.new .libs/libgcrypt.so.*.*
@touch libgcrypt.la.done