summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcus Brinkmann <mb@g10code.com>2009-12-08 20:36:35 +0000
committerMarcus Brinkmann <mb@g10code.com>2009-12-08 20:36:35 +0000
commit379ba9a761d1fa259e673ed9552fc2e73b5b2ea3 (patch)
treef85848ed7f9b86e95c6eef647bb531bdfe93ad30 /src/Makefile.am
parentff9ba101831234f3877e1b44eeab3c048e660828 (diff)
downloadlibgcrypt-379ba9a761d1fa259e673ed9552fc2e73b5b2ea3.tar.gz
2009-12-08 Marcus Brinkmann <marcus@g10code.de>
Update to libtool 2.2.6a. * configure.ac: Invoke AC_CONFIG_MACRO_DIR. (AC_LIBTOOL_WIN32_DLL, AC_LIBTOOL_RC): Replace by ... (LT_PREREQ, LT_INIT, LT_LANG): ... these. * config.guess, config.sub, install-sh, ltmain.sh, m4/libtool.m4: Updated to libtool 2.2.6a. * m4/ltoptions.m4, m4/ltsugar.m4, m4/ltversion.m4, m4/lt~obsolete.m4: New files from libtool 2.2.6a. src/ 2009-12-08 Marcus Brinkmann <marcus@g10code.de> * Makefile.am (LTRCCOMPILE): Refactor with ... (RCCOMPILE): ... this new macro. Add $(libgcrypt_la_CPPFLAGS). (SUFFIXES): Add .lo. (.rc.o): Change to ... (.rc.lo): ... this implicit rule. (gcrypt_res_ldflag): Removed. (gcrypt_res): Use libtool object file name here. (libgcrypt_la_LDFLAGS): Remove gcrypt_res_ldflag usage. (libgcrypt_la_LIBADD): Add gcrypt_res.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 9 insertions, 10 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 544b5e2e..08e6a04d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -52,16 +52,16 @@ libgcrypt_la_SOURCES = g10lib.h visibility.c visibility.h types.h \
if HAVE_W32_SYSTEM
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
- `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
- sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
+RCCOMPILE = $(RC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(libgcrypt_la_CPPFLAGS) $(AM_CPPFLAGS) $(CPPFLAGS)
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RCCOMPILE)
+
+SUFFIXES = .rc .lo
.rc.lo:
- $(LTRCCOMPILE) -i $< -o $@
+ $(LTRCCOMPILE) -i "$<" -o "$@"
gcrypt_res = versioninfo.lo
-gcrypt_res_ldflag = -Wl,.libs/versioninfo.o
-
no_undefined = -no-undefined
export_symbols = -export-symbols $(srcdir)/libgcrypt.def
@@ -87,7 +87,7 @@ gcrypt_deps =
endif !HAVE_W32_SYSTEM
-libgcrypt_la_LDFLAGS = $(gcrypt_res_ldflag) $(no_undefined) $(export_symbols) \
+libgcrypt_la_LDFLAGS = $(no_undefined) $(export_symbols) \
$(libgcrypt_version_script_cmd) -version-info \
@LIBGCRYPT_LT_CURRENT@:@LIBGCRYPT_LT_REVISION@:@LIBGCRYPT_LT_AGE@
libgcrypt_la_DEPENDENCIES = \
@@ -95,11 +95,10 @@ libgcrypt_la_DEPENDENCIES = \
../random/librandom.la \
../mpi/libmpi.la \
$(srcdir)/libgcrypt.vers $(gcrypt_deps)
-libgcrypt_la_LIBADD = \
+libgcrypt_la_LIBADD = $(gcrypt_res) \
../cipher/libcipher.la \
../random/librandom.la \
- ../mpi/libmpi.la \
- @LTLIBOBJS@ @GPG_ERROR_LIBS@
+ ../mpi/libmpi.la @LTLIBOBJS@ @GPG_ERROR_LIBS@
dumpsexp_SOURCES = dumpsexp.c