summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJussi Kivilinna <jussi.kivilinna@iki.fi>2016-12-10 12:29:12 +0200
committerJussi Kivilinna <jussi.kivilinna@iki.fi>2016-12-10 12:29:12 +0200
commitc83d0d2a26059cf471d09f5cb8e7fc5d76c4907b (patch)
tree7084e4777cf56bb508f5f77e490e775bddffd1e0 /tests/Makefile.am
parent2b7b227b8a0bd5ff286258bc187782efac180a7e (diff)
downloadlibgcrypt-c83d0d2a26059cf471d09f5cb8e7fc5d76c4907b.tar.gz
hwfeatures: add 'all' for disabling all hardware features
* .gitignore: Add 'tests/basic-disable-all-hwf'. * configure.ac: Ditto. * tests/Makefile.am: Ditto. * src/hwfeatures.c (_gcry_disable_hw_feature): Match 'all' for masking all HW features off. (parse_hwf_deny_file): Use '_gcry_disable_hw_feature' for matching. * tests/basic-disable-all-hwf.in: New. -- Also add new test to run 'basic' with all HWF disable. With current assembly implementations and build servers using new CPUs, generic implementations are not being tested enough anymore and compiler problems might end up unnoticed. Signed-off-by: Jussi Kivilinna <jussi.kivilinna@iki.fi>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 374e72e7..db51cbdf 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -26,7 +26,7 @@ tests_bin = \
tests_bin_last = benchmark bench-slope
-tests_sh =
+tests_sh = basic-disable-all-hwf
tests_sh_last = hashtest-256g
@@ -58,7 +58,8 @@ noinst_HEADERS = t-common.h
EXTRA_DIST = README rsa-16k.key cavs_tests.sh cavs_driver.pl \
pkcs1v2-oaep.h pkcs1v2-pss.h pkcs1v2-v15c.h pkcs1v2-v15s.h \
t-ed25519.inp stopwatch.h hashtest-256g.in \
- sha3-224.h sha3-256.h sha3-384.h sha3-512.h
+ sha3-224.h sha3-256.h sha3-384.h sha3-512.h \
+ basic-disable-all-hwf.in
LDADD = $(standard_ldadd) $(GPG_ERROR_LIBS)
t_lock_LDADD = $(standard_ldadd) $(GPG_ERROR_MT_LIBS)