summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-01-29 18:07:44 -0500
committerMike Frysinger <vapier@gmail.com>2018-01-30 17:58:44 -0500
commit14b8020ddaa7a127781aee169899d10a9079ca85 (patch)
tree4e8d1529c1ec93705d4e9afeee07c27713bb0053 /CMakeLists.txt
parent1daf261a831c5084bb78fb708d6d42a47f54df36 (diff)
downloadlibgd-14b8020ddaa7a127781aee169899d10a9079ca85.tar.gz
make gd/gd2 image formats optional #428
We still enable them by default, but we'll probably flip them off in the next major release series.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fe2eb4..f715b38 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,7 @@ SET(CMAKE_MODULE_PATH "${GD_SOURCE_DIR}/cmake/modules")
include(gd)
+OPTION(ENABLE_GD_FORMATS "Enable GD image formats" 0)
OPTION(ENABLE_PNG "Enable PNG support" 0)
OPTION(ENABLE_LIQ "Enable libimagequant support" 0)
OPTION(ENABLE_JPEG "Enable JPEG support" 0)
@@ -144,6 +145,8 @@ else (USE_EXT_GD)
FIND_PACKAGE(FontConfig)
endif (ENABLE_FONTCONFIG)
+ SET(ENABLE_GD_FORMATS ${ENABLE_GD_FORMATS})
+
if (FREETYPE_FOUND)
INCLUDE_DIRECTORIES(${FREETYPE_INCLUDE_DIRS})
SET(HAVE_FT2BUILD_H 1)