summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Joye <pierre.php@gmail.com>2021-08-21 17:52:54 +0700
committerPierre Joye <pierre.php@gmail.com>2021-08-21 17:52:54 +0700
commit2ddd6d30ea9454070c9132a5f9bc6dacb652c2f7 (patch)
tree2f94a61551543003c8b11031ccd34e7434f1f360 /CMakeLists.txt
parent30824ddc39199605f545ddcec9adb32bc8d90bee (diff)
downloadlibgd-2ddd6d30ea9454070c9132a5f9bc6dacb652c2f7.tar.gz
fix else syntax
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36f2dc7..cab71c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,9 +34,9 @@ endif(BUILD_TEST)
IF(CMAKE_COMPILER_IS_GNUCC)
# Re-enable sanitize once we find a way to filter out errors in external libraries (like HEIF)
if (ENABLE_ASAN)
- SET(CMAKE_C_FLAGS_DEBUG "-g -Wall -Wextra -O0 -fsanitize=address") # will be added to CMAKE_C_FLAGS when CMAKE_BUILD_TYPE is "Debug"
- else
- SET(CMAKE_C_FLAGS_DEBUG "-g -Wall -Wextra -O0 ") # will be added to CMAKE_C_FLAGS when CMAKE_BUILD_TYPE is "Debug"
+ SET(CMAKE_C_FLAGS_DEBUG "-g -Wall -Wextra -O0 -fsanitize=address") # will be added to CMAKE_C_FLAGS when CMAKE_BUILD_TYPE is Debug
+ else (ENABLE_ASAN)
+ SET(CMAKE_C_FLAGS_DEBUG "-g -Wall -Wextra -O0 ") # will be added to CMAKE_C_FLAGS when CMAKE_BUILD_TYPE is Debug
endif (ENABLE_ASAN)
ENDIF(CMAKE_COMPILER_IS_GNUCC)
SET (CMAKE_LIBRARY_OUTPUT_DIRECTORY