summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-07-22 15:09:04 +0530
committerMike Frysinger <vapier@gentoo.org>2016-07-22 15:09:04 +0530
commit5090a9ebf74004d28185d1350fc4b8ce69f54f82 (patch)
tree062c4fd3f4048d17203464dcdfa51e2c65b3993d /CMakeLists.txt
parent2b3dd57a6ccb2940f2e9119ae04e14362e2a1f61 (diff)
downloadlibgd-5090a9ebf74004d28185d1350fc4b8ce69f54f82.tar.gz
cmake: allow static libs to be disabled
The standard behavior in distros nowadays is to build shared libs and omit static libs. Split the build knobs in cmake to support this. It also matches what's available with the autotools build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb4304e..56260b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -193,7 +193,8 @@ else (USE_EXT_GD)
CONFIGURE_FILE(${GD_SOURCE_DIR}/src/config.h.cmake ${GD_SOURCE_DIR}/src/config.h ESCAPE_QUOTES)
- option(BUILD_SHARED_LIBS "Build both shared and static libs" ON)
+ option(BUILD_SHARED_LIBS "Build shared libs" ON)
+ option(BUILD_STATIC_LIBS "Build static libs" OFF)
if (WIN32)
SET(GD_LIB libgd)