summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLeo Yang <lyang@topologyinc.com>2015-08-27 12:41:25 -0400
committerLeo Yang <lyang@topologyinc.com>2015-08-27 13:11:37 -0400
commit7147b646f4de2eafc847730eaecee684183959e1 (patch)
tree15cb4c01ecfad00b5bd01581276ff31f642b866c /CMakeLists.txt
parent4751b606fa38edc456d627140898a7ec679fcc24 (diff)
downloadlibgd-7147b646f4de2eafc847730eaecee684183959e1.tar.gz
Make BUILD_SHARED_LIBS configurable
As previously build both shared and static if BUILD_SHARED_LIBS is ON. Otherwise build static only.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d2a564..7cf27ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,8 +191,7 @@ else (USE_EXT_GD)
CONFIGURE_FILE(${GD_SOURCE_DIR}/src/config.h.cmake ${GD_SOURCE_DIR}/src/config.h ESCAPE_QUOTES)
-
- set(BUILD_SHARED_LIBS On)
+ option(BUILD_SHARED_LIBS "Build both shared and static libs" ON)
if (WIN32)
SET(GD_LIB libgd)