summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwillson-chen <willson.chenwx@gmail.com>2020-05-06 17:17:33 +0800
committerMike Frysinger <vapier@gmail.com>2020-05-07 23:55:01 -0400
commit78b1f2bdf3a7b6ee5aa7148e88f6d6f53f4c7e10 (patch)
treeab8ce4849d5b549ddcd1ce54d48f93490dfaef6f /CMakeLists.txt
parent7cb597af4a4b1fb3e372a4e09674734b3f68019c (diff)
downloadlibgd-78b1f2bdf3a7b6ee5aa7148e88f6d6f53f4c7e10.tar.gz
CMakeLists.txt: zlib is enabled implicitly
zlib is enabled only when ENABLE_PNG or ENABLE_GD_FORMATS is on.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dbe78e6..9004394 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,7 +100,12 @@ else (USE_EXT_GD)
include(AC_HEADER_STDC)
include(CheckPrototypeExists)
+ if (ENABLE_GD_FORMATS)
+ FIND_PACKAGE(ZLIB)
+ endif (ENABLE_GD_FORMATS)
+
if (ENABLE_PNG)
+ FIND_PACKAGE(ZLIB)
FIND_PACKAGE(PNG REQUIRED)
endif (ENABLE_PNG)
@@ -108,8 +113,6 @@ else (USE_EXT_GD)
FIND_PACKAGE(ICONV REQUIRED)
endif (ENABLE_ICONV)
- FIND_PACKAGE(ZLIB)
-
IF (ENABLE_WEBP)
FIND_PACKAGE(WEBP)
ENDIF (ENABLE_WEBP)