summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwillson-chen <willson.chenwx@gmail.com>2019-11-01 21:26:53 +0800
committerMike Frysinger <vapier@gmail.com>2019-11-02 00:59:43 -0600
commitac7118680d2258ee884378b8815b50131ed5c4f0 (patch)
tree8de3f9cf0c477c4a1c517fca813881bd5f42363e /CMakeLists.txt
parent2874546a44e5067fa1041b4b9dc870436fe6ee61 (diff)
downloadlibgd-ac7118680d2258ee884378b8815b50131ed5c4f0.tar.gz
Fix #539: Add RAQM support for cmake
* Add `ENABLE_RAQM` option to CMakeLists.txt * Add cmake module FindRAQM.cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f89188a..4f11858 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,7 @@ OPTION(ENABLE_XPM "Enable XPM support" 0)
OPTION(ENABLE_FREETYPE "Enable Freetype2 support" 0)
OPTION(ENABLE_FONTCONFIG "Enable FontConfig support" 0)
OPTION(ENABLE_WEBP "Enable WebP support" 0)
+OPTION(ENABLE_RAQM "Enable RAQM support" 0)
if (BUILD_TEST)
ENABLE_TESTING()
@@ -143,6 +144,10 @@ else (USE_EXT_GD)
FIND_PACKAGE(FontConfig)
endif (ENABLE_FONTCONFIG)
+ if (ENABLE_RAQM)
+ FIND_PACKAGE(RAQM)
+ endif (ENABLE_RAQM)
+
SET(ENABLE_GD_FORMATS ${ENABLE_GD_FORMATS})
if (FREETYPE_FOUND)
@@ -201,6 +206,10 @@ else (USE_EXT_GD)
SET(FONTCONFIG_LIB_DIR "")
ENDIF(FONTCONFIG_FOUND)
+ IF(RAQM_FOUND)
+ INCLUDE_DIRECTORIES(${RAQM_INCLUDE_DIR})
+ ENDIF(RAQM_FOUND)
+
SET(HAVE_CONFIG_H 1)
ADD_DEFINITIONS(-DHAVE_CONFIG_H)