summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-30 16:25:09 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-30 21:02:45 -0400
commitadc8598dcb19ac70c588b6298418df7b7c274bc2 (patch)
tree6fdb80981688d9ef1bb53e3696bb383a89135c88 /CMakeLists.txt
parentef9b000d39e2c1092ec4d98ce135eff385c05f4b (diff)
downloadlibgd-adc8598dcb19ac70c588b6298418df7b7c274bc2.tar.gz
tests: unify cmake test code into a single macro
This makes the test code a lot easier to manage rather than copying & pasting the same boiler plate multiple times. Also take the opportunity to add a common prefix to each test name so we don't get collisions between subdirs if a test happens to use the same exact name.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7cf27ef..07e7e79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,8 @@ PROJECT(GD)
SET(CMAKE_MODULE_PATH "${GD_SOURCE_DIR}/cmake/modules")
+include(gd)
+
OPTION(ENABLE_PNG "Enable PNG support" 0)
OPTION(ENABLE_LIQ "Enable libimagequant support" 0)
OPTION(ENABLE_JPEG "Enable JPEG support" 0)