summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpajoye <none@none>2008-02-27 13:27:49 +0000
committerpajoye <none@none>2008-02-27 13:27:49 +0000
commitc9972ade5697bfc4763f3afa7a50a5bd10a36e82 (patch)
treec33a1f80075c041913b0b42392771eca9407e511 /CMakeLists.txt
parentced7239a834ecaf16e3b7961a01204893ac8650b (diff)
downloadlibgd-c9972ade5697bfc4763f3afa7a50a5bd10a36e82.tar.gz
- enable all features by default, can be disabled one by one
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df6a79c..15692de 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,6 +30,14 @@ set(CPACK_SOURCE_IGNORE_FILES
INCLUDE(CPack)
SET(CMAKE_MODULE_PATH "${GD_SOURCE_DIR}/cmake/modules")
+OPTION(ENABLE_PNG "Enable PNG support" 1)
+OPTION(ENABLE_JPEG "Enable JPEG support" 1)
+OPTION(ENABLE_TIFF "Enable TIFF support" 1)
+OPTION(ENABLE_XPM "Enable XPM support" 1)
+OPTION(ENABLE_FREETYPE "Enable Freetype2 support" 1)
+OPTION(ENABLE_WBMP "Enable WBMP support" 1)
+OPTION(ENABLE_FONTCONFIG "Enable FontConfig support" 1)
+
if (BUILD_TEST)
ENABLE_TESTING()
endif(BUILD_TEST)