summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGregory Boyce <gregb@activestate.com>2021-07-15 15:39:15 -0400
committerGregory Boyce <gregb@activestate.com>2021-07-15 15:39:15 -0400
commitf8cd3dbbc74bcdca4c0ad7bcbef636efb29eaad0 (patch)
treeff421de5fdb3873ad9cc637e2c9d44b50424cd66 /CMakeLists.txt
parentbf36fa539be8f6ddcba2dc2b0d5e97be6fda2404 (diff)
downloadlibgd-f8cd3dbbc74bcdca4c0ad7bcbef636efb29eaad0.tar.gz
Set GD_LIB to gd on mingw
Setting GD_LIB to libgd on MINGW builds results in liblibgd.a and liblibgd.dll.a being built.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 377d397..8a2d79f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -261,6 +261,7 @@ else (USE_EXT_GD)
ADD_DEFINITIONS("/D_CRT_SECURE_NO_DEPRECATE")
endif(NOT MINGW AND MSVC_VERSION GREATER 1399)
if (MINGW OR MSYS)
+ SET(GD_LIB gd)
ADD_DEFINITIONS("-mms-bitfields") # -m32
endif (MINGW OR MSYS)
else (WIN32)