summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-24 03:51:05 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-24 03:51:05 -0400
commit82586ee739583ad1a779981b4eb4bd16e790f533 (patch)
treea94f8cb2b3a7a8b7f8d76c414126566440cff219 /Makefile.am
parentb57b5a0043d8194f1baa60d5a464029197fdbe9f (diff)
downloadlibgd-82586ee739583ad1a779981b4eb4bd16e790f533.tar.gz
build: have `make clean` clear out cmake files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 033b91a..2ecf6ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,14 @@
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = src config tests
EXTRA_DIST = test docs examples windows VMS cmake netware bootstrap.sh CMakeLists.txt CONTRIBUTORS README.md
+
+clean-local:
+ find -maxdepth 3 \
+ '(' \
+ -name CMakeCache.txt -o \
+ -name CMakeFiles -o \
+ -name CTestTestfile.cmake -o \
+ -name cmake_install.cmake \
+ ')' \
+ -exec rm -rf {} +
+ rm -rf Bin CPackConfig.cmake CPackSourceConfig.cmake