summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-05-17 23:06:14 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-17 23:06:14 -0400
commit1239832a09b160a21a092cafcef56c3c16f554f1 (patch)
tree69fd7d3c60b6101dde9fafbba0cc07c2d08891c7 /configure.ac
parent32c5072fd65f4692a728c802adb403ccf5c8d7e9 (diff)
downloadlibgd-1239832a09b160a21a092cafcef56c3c16f554f1.tar.gz
configure/cmake: unify header checks and config.h generation
Rather than hand maintain config.h.cmake (which is already out of date), re-use the autogenerated config.h from autoheader.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e8ee78f..0f21969 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,8 +73,22 @@ if test -n "$x_libraries" && test "x$x_libraries" != xNONE ; then
LDFLAGS="$LDFLAGS -L$x_libraries"
fi
+dnl Keep in sync with cmake/modules/AC_HEADER_STDC.cmake.
AC_HEADER_STDC
-AC_CHECK_HEADERS([errno.h limits.h stddef.h stdlib.h string.h unistd.h])
+AC_CHECK_HEADERS_ONCE(m4_flatten([
+ dirent.h
+ errno.h
+ inttypes.h
+ limits.h
+ stddef.h
+ stdint.h
+ stdlib.h
+ string.h
+ strings.h
+ unistd.h
+ sys/stat.h
+ sys/types.h
+]))
dnl if we're configuring on a system w/out gettext, don't fall over
m4_ifndef([AM_ICONV],[m4_define([AM_ICONV],[:])])