summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhalid Alqassabi <khq94k@gmail.com>2016-06-30 13:19:25 +0400
committerKhalid Alqassabi <khq94k@gmail.com>2016-06-30 13:19:25 +0400
commit1dbccb737c5e9634085c9a3239fa1e0d0b988966 (patch)
tree6284faa77c4324f5eafc3085b1d028f5a222a46c /configure.ac
parent3fe0a7128bac5000fdcfab888bd2a75ec0c9447d (diff)
downloadlibgd-1dbccb737c5e9634085c9a3239fa1e0d0b988966.tar.gz
Add complex text layout support
This pull request (based on Asma's works) adds support for languages that require [complex text layout](https://en.wikipedia.org/wiki/Complex_text_layout). We are using [libraqm](https://github.com/HOST-Oman/libraqm), a small source code-only library that wraps FriBidi (for bidirectional text support) and HarfBuzz (for text shaping), and does proper BiDi and script itemization. The CTL support is enabled by default but can be disabled at compiling time, and we provide a fallback function that uses your original code without CTL support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9d3d1fe..360516a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,6 +233,14 @@ if test "$gd_with_LIBFREETYPE" = "yes"; then
AC_DEFINE([HAVE_FT2BUILD_H], [1], [Define if you have the ft2build.h header.])
fi
+dnl Check for Raqm support.
+GD_LIB_PKG_CHECK([LIBRAQM], [RAQM], [raqm], [raqm], [
+ AC_CHECK_LIB([raqm], [raqm_create], [dnl
+ AS_VAR_APPEND([LIBRAQM_LIBS], [" -lraqm -lfreetype"])
+ gd_found_lib=yes
+ ])
+])
+
dnl Check for fontconfig support.
GD_LIB_PKG_CHECK([LIBFONTCONFIG], [FONTCONFIG], [fontconfig], [fontconfig], [
AC_CHECK_LIB([fontconfig], [FcInit], [dnl
@@ -318,6 +326,7 @@ AC_MSG_RESULT([
Support for Fontconfig library: $gd_with_LIBFONTCONFIG
Support for Xpm library: $gd_with_LIBXPM
Support for liq library: $gd_with_LIBIMAGEQUANT
+ Support for complext text: $gd_with_LIBRAQM
Support for pthreads: $ax_pthread_ok
])