summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-03 20:09:37 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-03 20:09:37 -0400
commit70ecd2126d71503b21beb66bd4b3376c5c3e0279 (patch)
treeabcbcbd3d3da2371ef82d0dda2dc26cf455498db /configure.ac
parentc7c7e23a393e2daf657ce598c639a04fef5e49b8 (diff)
downloadlibgd-70ecd2126d71503b21beb66bd4b3376c5c3e0279.tar.gz
configure: build with -Wall by default
This makes -Werror more effective (which we already utilize).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af4fb9f..9d3d1fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -295,6 +295,9 @@ if test "$mingw_cv_win32_host" = yes; then
AC_DEFINE([BGDWIN32], [], [Define is you are building for Win32 API])
fi
+dnl Enable -Wall if possible. Do it after all other tests.
+AX_CFLAGS_WARN_ALL
+
dnl Enable -Werror if possible. Do it after all other tests.
AC_ARG_ENABLE([werror], [AS_HELP_STRING([--enable-werror], [treat compile warnings as errors])])
if test "$enable_werror" = "yes" || test "$GCC" = "yes" -a "$enable_werror" != "no"; then