summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-11-10 09:07:27 -0500
committerMike Frysinger <vapier@gentoo.org>2016-11-10 09:07:33 -0500
commit7e87587205eb12bc50bc6f6044a36581c3d89138 (patch)
treeb9b93fa82f00aa84d863c37cf68a0e3e1842f252 /configure.ac
parent939d49a3a9d1cbcd2a37cea9eac9f9e5e9f9de78 (diff)
downloadlibgd-7e87587205eb12bc50bc6f6044a36581c3d89138.tar.gz
configure: only enable -Werror by default in git builds #339
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f7a943f..91643bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -301,7 +301,8 @@ AX_CFLAGS_WARN_ALL
dnl Enable -Werror if possible. Do it after all other tests.
AC_ARG_ENABLE([werror], [AS_HELP_STRING([--enable-werror], [treat compile warnings as errors])])
-if test "$enable_werror" = "yes" || test "$GCC" = "yes" -a "$enable_werror" != "no"; then
+if test "$enable_werror" = "yes" || \
+ test "$GCC" = "yes" -a "$enable_werror" != "no" -a -d "$srcdir/.git"; then
CFLAGS="-Werror $CFLAGS"
CXXFLAGS="-Werror $CXXFLAGS"
fi