summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-05-18 02:34:45 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-18 02:34:45 -0400
commitb64c996b070c67f1748c25b79ca31db922ceac6d (patch)
tree0596bf165572534dd7bf13c5ef789afae7fcc123 /configure.ac
parent10a491511437250e39428a45ec57f244c253f899 (diff)
downloadlibgd-b64c996b070c67f1748c25b79ca31db922ceac6d.tar.gz
build: fix GDLIB_REVISION collision
We are using GDLIB_REVISION to refer to the gd version string (the "z" in "x.y.z"), and we are using it to control the libtool revision field. This leads to problems where the version increases (e.g. "2.1.1") but the libtool revision doesn't (e.g. "0"). So scripts end up seeing a revision of "0" in their output instead of "1". Namespace the libtool version variables with "_LT_" to avoid any more collisions. Fixes #140.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0f21969..f54e6a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,12 +37,12 @@ AC_SUBST(GDLIB_VERSION)
# Dynamic library version information
# See http://www.gnu.org/software/libtool/manual/libtool.html#Updating-version-info
-GDLIB_CURRENT=3
-GDLIB_REVISION=0
-GDLIB_AGE=0
-AC_SUBST(GDLIB_CURRENT)
-AC_SUBST(GDLIB_REVISION)
-AC_SUBST(GDLIB_AGE)
+GDLIB_LT_CURRENT=3
+GDLIB_LT_REVISION=0
+GDLIB_LT_AGE=0
+AC_SUBST(GDLIB_LT_CURRENT)
+AC_SUBST(GDLIB_LT_REVISION)
+AC_SUBST(GDLIB_LT_AGE)
#Expanded by tests later in this file. TBB 2.0.26
#2.0.28: GIF is standard now. Doesn't depend on anything else,