summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorChristoph M. Becker <cmbecker69@gmx.de>2016-11-12 15:00:31 +0100
committerChristoph M. Becker <cmbecker69@gmx.de>2016-12-13 16:02:19 +0100
commit1846f48e5fcdde996e7c27a4bbac5d0aef183e4b (patch)
tree4731c5afba12dd09bfaba28655ca52ca3fa4d9cc /tests/CMakeLists.txt
parent58b6dde319c301b0eae27d12e2a659e067d80558 (diff)
downloadlibgd-1846f48e5fcdde996e7c27a4bbac5d0aef183e4b.tar.gz
Fix #340: System frozen
gdImageCreate() doesn't check for oversized images and as such is prone to DoS vulnerabilities. We fix that by applying the same overflow check that is already in place for gdImageCreateTrueColor(). CVE-2016-9317
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index c4fa9ca..7eef4bf 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -38,6 +38,7 @@ if (BUILD_TEST)
gdimagecopy
gdimagecopyresampled
gdimagecopyrotated
+ gdimagecreate
gdimagecrop
gdimagefile
gdimagefill