summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorChristoph M. Becker <cmbecker69@gmx.de>2016-07-16 20:00:39 +0200
committerChristoph M. Becker <cmbecker69@gmx.de>2016-07-17 18:41:17 +0200
commite7e20d67d7e51f5a1ed77b5c93afd1c015fe8906 (patch)
tree6f8ecc8522b0871a9d7a283e90709d49fe65c812 /tests/CMakeLists.txt
parent763cd194da05804defa666a9053d2ce569f3a9fb (diff)
downloadlibgd-e7e20d67d7e51f5a1ed77b5c93afd1c015fe8906.tar.gz
No pixel of a filled arc must ever be drawn multiple times
Otherwise we get artifacts regarding transparency. That happens with the current implementation of gdImageFilledArc() unless gdChord or gdNoFill are set. When gdPie is set, however, the filled arc is drawn in wedges, which are polygons of three points, and so some overlap is natural. To resolve the issue, we stick with the current algorithm of calculating the wedges, but instead of drawing each polygon separately, we put the *relevant* points in a large array, and draw a single polygon. That also is supposed to improve the performance considerably. Note that this modification will change the results when gdImageSetStyle() or gdImageSetBrush() are used, but we believe that this modification is also an improvement in this regard, even though it still might not make much sense to use these functions with gdImageFilledArc().
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 369dec7..61aded5 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -34,6 +34,7 @@ if (BUILD_TEST)
gdimagecrop
gdimagefile
gdimagefill
+ gdimagefilledarc
gdimagefilledellipse
gdimagefilledpolygon
gdimagefilledrectangle