summaryrefslogtreecommitdiff
path: root/tests/gdimagefile/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Silverstein <adamjs@google.com>2021-05-05 09:30:02 -0600
committerAdam Silverstein <adamjs@google.com>2021-05-05 09:30:02 -0600
commita2b3ba08ef945e472de9ceeef2b748eb4028cf7a (patch)
tree9ef6e2ddfe95b2ed9267965df2dcca4beb72755e /tests/gdimagefile/CMakeLists.txt
parent3826c44e52b4d2e4c06eae3aca908246465b6968 (diff)
parent82d260950589563a1af9c56f4ce5fde843a695ae (diff)
downloadlibgd-a2b3ba08ef945e472de9ceeef2b748eb4028cf7a.tar.gz
Merge branch 'master' into webp-lossless
# Conflicts: # tests/webp/.gitignore # tests/webp/CMakeLists.txt # tests/webp/Makemodule.am
Diffstat (limited to 'tests/gdimagefile/CMakeLists.txt')
-rw-r--r--tests/gdimagefile/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/gdimagefile/CMakeLists.txt b/tests/gdimagefile/CMakeLists.txt
index 55ae374..8676264 100644
--- a/tests/gdimagefile/CMakeLists.txt
+++ b/tests/gdimagefile/CMakeLists.txt
@@ -1,5 +1,11 @@
+IF(TIFF_FOUND)
+IF(WEBP_FOUND)
+IF(ENABLE_GD_FORMATS)
LIST(APPEND TESTS_FILES
gdnametest
)
+ENDIF(ENABLE_GD_FORMATS)
+ENDIF(WEBP_FOUND)
+ENDIF(TIFF_FOUND)
ADD_GD_TESTS()