summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cab71c0..862d8e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,7 @@ OPTION(ENABLE_HEIF "Enable HEIF support" 0)
OPTION(ENABLE_AVIF "Enable AVIF support" 0)
OPTION(ENABLE_RAQM "Enable RAQM support" 0)
OPTION(ENABLE_ASAN "Enable (gcc) ASAN support" 0)
+OPTION(ENABLE_CPP "Enable CPP GD API" 1)
if (BUILD_TEST)
ENABLE_TESTING()
@@ -110,6 +111,10 @@ else (USE_EXT_GD)
include(AC_HEADER_STDC)
include(CheckPrototypeExists)
+ if (ENABLE_CPP)
+ SET(ENABLE_CPP_API 1)
+ endif (ENABLE_CPP)
+
if (ENABLE_GD_FORMATS)
FIND_PACKAGE(ZLIB REQUIRED)
endif (ENABLE_GD_FORMATS)