summaryrefslogtreecommitdiff
path: root/tests/jpeg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/jpeg/CMakeLists.txt')
-rw-r--r--tests/jpeg/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/tests/jpeg/CMakeLists.txt b/tests/jpeg/CMakeLists.txt
index e8ecf63..ff188a9 100644
--- a/tests/jpeg/CMakeLists.txt
+++ b/tests/jpeg/CMakeLists.txt
@@ -1,12 +1,19 @@
IF(JPEG_FOUND)
LIST(APPEND TESTS_FILES
+ jpeg_empty_file
jpeg_im2im
+ jpeg_ptr_double_free
jpeg_null
- jpeg_read
- jpeg_empty_file
jpeg_resolution
+)
+
+IF(PNG_FOUND)
+LIST(APPEND TESTS_FILES
bug_github_18
+ jpeg_read
+ bug00338
)
+ENDIF(PNG_FOUND)
ENDIF(JPEG_FOUND)
ADD_GD_TESTS()